00:00
00:00

Reviews for "Four Second Firestorm"

I have 10 too!!!!

My bro. says that we have Flash Player 10. It says it's 8 or earlier?!?!? wtf

lame...

this must be the worlds best game that most people can't play...sigh...

wtf

we cant play. bull****.

why?

why cant i play it!

WTF!?!?!?!?!

it won't let me play i don't know why i have flash player 9 and 10 and it won't let me it just stayed at the loading screen