Be a Supporter!

Review submission not working

  • 313 Views
  • 8 Replies
New Topic Respond to this Topic
Kreuvf
Kreuvf
  • Member since: May. 16, 2012
  • Offline.
Forum Stats
Supporter
Level 01
Voice Actor
Review submission not working Jan. 3rd, 2013 @ 01:57 PM Reply

When submitting a review the final step is to click the "submit" button. Unfortunately, doing this has no effect. The check box for having read and understood the review guidelines is ticked.

I'm using Firefox (with several extensions) and I have two different profiles: one with all paranoid extensions for privacy/security blablabla and one that is supposed to "just work" (accepts all cookies, JavaScript is welcome, etc. pp. you get the idea). It does not work with any of the two, the behaviour is exactly the same.

So, if anyone out there has any clue on what is going wrong and how to fix it, please tell me.


Only encrypted communication is good communication.

Omega
Omega
  • Member since: Nov. 3, 2012
  • Offline.
Forum Stats
Member
Level 11
Writer
Response to Review submission not working Jan. 3rd, 2013 @ 10:58 PM Reply

If its an problem with your connection, that might be the problem.


"Nermal is a piece of shit." Darthdenim

BBS Signature
Kreuvf
Kreuvf
  • Member since: May. 16, 2012
  • Offline.
Forum Stats
Supporter
Level 01
Voice Actor
Response to Review submission not working Jan. 6th, 2013 @ 08:37 AM Reply

At 1/3/13 10:58 PM, OmegaweaponV5 wrote: If its an problem with your connection, that might be the problem.

Reminds me of Honor Societies.

The problem solved itself for no apparent reason. Weird stuff is weird.


Only encrypted communication is good communication.

Kreuvf
Kreuvf
  • Member since: May. 16, 2012
  • Offline.
Forum Stats
Supporter
Level 01
Voice Actor
Response to Review submission not working Feb. 9th, 2013 @ 02:22 PM Reply

At 1/3/13 01:57 PM, Kreuvf wrote: So, if anyone out there has any clue on what is going wrong and how to fix it, please tell me.

After having the same problem again, I think I managed to find the root of the problem.

Usually my browser is set to use HTTPS if possible. Now the problem seems to be that when opening the page via HTTPS the form still uses HTTP for POSTing the data.

See the value of the action attribute of the form element.

<form id="review_form" action="http://www.newgrounds.com/portal/reviews/submit/" method="post" class="podcontent" style="">
	<!-- remaining parts of the form removed for brevity -->
</form>

Non-satisfying workaround: Re-open submission using bare HTTP.

If someone @NG wants to fix this/needs more information on this issue, please contact me.


Only encrypted communication is good communication.

Cyberdevil
Cyberdevil
  • Member since: Jan. 17, 2004
  • Offline.
Forum Stats
Supporter
Level 50
Writer
Response to Review submission not working Feb. 10th, 2013 @ 02:51 AM Reply

At 2/9/13 02:22 PM, Kreuvf wrote: If someone @NG wants to fix this/needs more information on this issue, please contact me.

Or... you could contact them and make them aware of the issue. :)

Kreuvf
Kreuvf
  • Member since: May. 16, 2012
  • Offline.
Forum Stats
Supporter
Level 01
Voice Actor
Response to Review submission not working Feb. 10th, 2013 @ 02:55 AM Reply

At 2/10/13 02:51 AM, Cyberdevil wrote:
At 2/9/13 02:22 PM, Kreuvf wrote: If someone @NG wants to fix this/needs more information on this issue, please contact me.
Or... you could contact them and make them aware of the issue. :)

Oh, so posting on this forum is/was the wrong place... Well, thanks for that information. The next questions are: how and who to contact?


Only encrypted communication is good communication.

Cyberdevil
Cyberdevil
  • Member since: Jan. 17, 2004
  • Offline.
Forum Stats
Supporter
Level 50
Writer
Response to Review submission not working Feb. 10th, 2013 @ 03:01 AM Reply

At 2/10/13 02:55 AM, Kreuvf wrote:
At 2/10/13 02:51 AM, Cyberdevil wrote:
At 2/9/13 02:22 PM, Kreuvf wrote: If someone @NG wants to fix this/needs more information on this issue, please contact me.
Or... you could contact them and make them aware of the issue. :)
Oh, so posting on this forum is/was the wrong place... Well, thanks for that information. The next questions are: how and who to contact?

Posting at the forums is the right place to get answers, and it's where users can help each other. Admins don't browse all topics though, so the best way would be to send them a PM. There's a list on the Staff page. Wade generally takes care of account-related issues.

Kreuvf
Kreuvf
  • Member since: May. 16, 2012
  • Offline.
Forum Stats
Supporter
Level 01
Voice Actor
Response to Review submission not working Feb. 10th, 2013 @ 06:25 AM Reply

At 2/10/13 03:01 AM, Cyberdevil wrote: Posting at the forums is the right place to get answers, and it's where users can help each other. Admins don't browse all topics though, so the best way would be to send them a PM. There's a list on the Staff page. Wade generally takes care of account-related issues.

Thanks!


Only encrypted communication is good communication.

Cyberdevil
Cyberdevil
  • Member since: Jan. 17, 2004
  • Offline.
Forum Stats
Supporter
Level 50
Writer
Response to Review submission not working Feb. 10th, 2013 @ 07:09 AM Reply

At 2/10/13 06:25 AM, Kreuvf wrote: Thanks!

No problem :)