Be a Supporter!

flash bugs and constant glitches

  • 916 Views
  • 12 Replies
New Topic Respond to this Topic
palodigon
palodigon
  • Member since: Mar. 6, 2008
  • Offline.
Forum Stats
Member
Level 28
Game Developer
flash bugs and constant glitches Aug. 29th, 2012 @ 08:07 AM Reply

Sometimes when I go to a next frame or next scene this happens:
- Randomly and suddenly goes to scene 1 frame 1
- Everything on screen is suddenly removed, I get a bluescreen ( my background color) but the music is still playing.

Again, this only happens sometimes. Sometimes it works fine and sometimes one of those bugs happens so it's not a fault in my programming.

has anyone ever heard of this bug before and/or knows how to fix this?
I'm using adobe flash CS6.

(also: how do I turn off autosave, it annoys me so much and I can't turn it off in preferences. Auto-recovery is turned off in my preferences.)

palodigon
palodigon
  • Member since: Mar. 6, 2008
  • Offline.
Forum Stats
Member
Level 28
Game Developer
Response to flash bugs and constant glitches Aug. 29th, 2012 @ 08:16 AM Reply

A bit of further explanation: when I go to a next scene. It stays there for a random amount of frames (I've tried it 3 times, the first time it happened after 22 frames, then 11 frames and after that after 26 frames) and then suddenly goes back to scene 1, frame 1.
My frame rate is 24 frames/second. I'm pretty desperate. I've been working on this for months and this stupid glitch is ruining it for me.

Mufanza
Mufanza
  • Member since: Aug. 22, 2009
  • Offline.
Forum Stats
Member
Level 09
Blank Slate
Response to flash bugs and constant glitches Aug. 29th, 2012 @ 11:54 AM Reply

At 8/29/12 08:07 AM, palodigon wrote: Again, this only happens sometimes. Sometimes it works fine and sometimes one of those bugs happens so it's not a fault in my programming.

I wouldn't be so sure, this is no proof :S
If you still think it's the Flash's fault (which I doubt), try to reinstall it completely along with flash player. It probably won't help, since the fault is most likely in your programming, but you will be at least sure you should check your code some more.

Diki
Diki
  • Member since: Jan. 31, 2004
  • Offline.
Forum Stats
Moderator
Level 13
Programmer
Response to flash bugs and constant glitches Aug. 29th, 2012 @ 11:58 AM Reply

At 8/29/12 08:07 AM, palodigon wrote: Again, this only happens sometimes. Sometimes it works fine and sometimes one of those bugs happens so it's not a fault in my programming.

I don't know why you're getting that erroneous behavior, but I can guarantee it's your code that's doing it.
Use a debugger to determine what piece of code is causing that to happen, and then post that code here (if you're not able to discern the issue on your own).

Mr-Shark
Mr-Shark
  • Member since: Dec. 11, 2001
  • Offline.
Forum Stats
Member
Level 20
Game Developer
Response to flash bugs and constant glitches Aug. 29th, 2012 @ 03:46 PM Reply

At 8/29/12 11:58 AM, Diki wrote:
At 8/29/12 08:07 AM, palodigon wrote: Again, this only happens sometimes. Sometimes it works fine and sometimes one of those bugs happens so it's not a fault in my programming.
I don't know why you're getting that erroneous behavior, but I can guarantee it's your code that's doing it.
Use a debugger to determine what piece of code is causing that to happen, and then post that code here (if you're not able to discern the issue on your own).

let me see the .swf and tell me where the problem is. normally it's some stupid small error, typo, things not being declared properally.

palodigon
palodigon
  • Member since: Mar. 6, 2008
  • Offline.
Forum Stats
Member
Level 28
Game Developer
Response to flash bugs and constant glitches Aug. 29th, 2012 @ 04:06 PM Reply

I've spend hours trying to find out what's wrong. I don't know how to debug, I tried but I have no clue how it works. But there seems to be something wrong with the gotoAndStop. It's strange that it only happens sometimes. It goes to the frame it's supposed to for about half a second and then goes all the xway back to frame 1; scene 1 for no reason.

I'll put you in beta tester shark, I hope you can help me.

MSGhero
MSGhero
  • Member since: Dec. 15, 2010
  • Offline.
Forum Stats
Supporter
Level 16
Game Developer
Response to flash bugs and constant glitches Aug. 29th, 2012 @ 06:36 PM Reply

At 8/29/12 04:06 PM, palodigon wrote: I've spend hours trying to find out what's wrong. I don't know how to debug, I tried but I have no clue how it works. But there seems to be something wrong with the gotoAndStop. It's strange that it only happens sometimes. It goes to the frame it's supposed to for about half a second and then goes all the xway back to frame 1; scene 1 for no reason.

I'll put you in beta tester shark, I hope you can help me.

Maybe you are switching frames before finishing a block of code or something weird. Happened to my friend at least.

That's why you don't code on frames...
Mr-Shark
Mr-Shark
  • Member since: Dec. 11, 2001
  • Offline.
Forum Stats
Member
Level 20
Game Developer
Response to flash bugs and constant glitches Aug. 29th, 2012 @ 07:46 PM Reply

never recieved a beta invite

palodigon
palodigon
  • Member since: Mar. 6, 2008
  • Offline.
Forum Stats
Member
Level 28
Game Developer
Response to flash bugs and constant glitches Aug. 30th, 2012 @ 05:56 AM Reply

At 8/29/12 07:46 PM, Mr-Shark wrote: never recieved a beta invite

I've send you a PM.

palodigon
palodigon
  • Member since: Mar. 6, 2008
  • Offline.
Forum Stats
Member
Level 28
Game Developer
Response to flash bugs and constant glitches Aug. 30th, 2012 @ 08:04 AM Reply

Also: when I put the same code in a button, it works perfectly. But it doesn't when it's in a movieclip.

palodigon
palodigon
  • Member since: Mar. 6, 2008
  • Offline.
Forum Stats
Member
Level 28
Game Developer
Response to flash bugs and constant glitches Sep. 3rd, 2012 @ 06:55 AM Reply

Ok it seems noone here can help me. Wich sucks because more and more bugs have appeared. Right now some movieclips don't even load anymore on the screen.

palodigon
palodigon
  • Member since: Mar. 6, 2008
  • Offline.
Forum Stats
Member
Level 28
Game Developer
Response to flash bugs and constant glitches Sep. 3rd, 2012 @ 08:19 AM Reply

Right now a part that worked fine all the time and wich I have made months ago stopped working. It doesn't show up on stage. A simple trace said it's visible but it isn't. This is absurd.

And I can't add text anymore either. A static text will show, but when I change it to dynamic it dissapears (trace says it's visible though).

This is absurd.

For the people who still think it's my code, I can send you the file, I dare you to find what's wrong with my programming that could cause these problems.

pirateplatypus
pirateplatypus
  • Member since: Sep. 27, 2011
  • Offline.
Forum Stats
Member
Level 15
Programmer
Response to flash bugs and constant glitches Sep. 3rd, 2012 @ 12:50 PM Reply

At 9/3/12 06:55 AM, palodigon wrote: Ok it seems noone here can help me.

Y'know, it's awfully hard to help you with problems in your code when you don't post any code.


"If loving Python is crazy then I don't want to be sane." -Diki