Be a Supporter!

What is happening here!?!?!

  • 398 Views
  • 6 Replies
New Topic Respond to this Topic
RyanAndIdk
RyanAndIdk
  • Member since: Aug. 18, 2010
  • Offline.
Forum Stats
Member
Level 04
Animator
What is happening here!?!?! Jun. 29th, 2012 @ 08:46 PM Reply

I finished my entire animation an put the sounds in the right spot but it keeps playing before its supposed to! i went through the animation and took out all the tweens but it proceeds to play the sound on a different fame! This has happened before and i took about an hour trying to figure it out but each time it still wouldn't work! I got so frustrated i smashed my hand on my desk and nearly sprained it please help!

bl00db47h
bl00db47h
  • Member since: Sep. 8, 2008
  • Offline.
Forum Stats
Member
Level 15
Animator
Response to What is happening here!?!?! Jun. 29th, 2012 @ 09:10 PM Reply

It might be that you just have the wrong setting on. Make sure that all the sounds are on a different layer from the animation. Now click on any frame (it doesn't matter which) and open the properties panel. You see the 'sync' option underneath effects? It will probably be set on event, change it to STREAM.

Hopefully this will help. Pic included since I'm terrible at explaining things, this'll probably help you out more :P

What is happening here!?!?!


The Problems of the Future, by Everyone!

Jurgen
Jurgen
  • Member since: Sep. 6, 2008
  • Offline.
Forum Stats
Member
Level 22
Animator
Response to What is happening here!?!?! Jul. 4th, 2012 @ 10:41 PM Reply

This happened to me with one of my flashes, and is now happening with a flash I'm working on now. It's frusterating as hell.

The last one though, someone suggested I put all the sounds in a movie clip. This ended up being what I did, though it may be a bit tedious. Just assemble all your sounds the way they are suppose to be, synced up and whatnot, then copy and paste the frames in a new movie clip...I think that's what I did, either way it shouldn't be too hard to figure out.

I too, would like to know the cause of this though.


GamerTag: MEGAxCptnWalrus

ExtremeFudgeMaster
ExtremeFudgeMaster
  • Member since: Apr. 9, 2004
  • Offline.
Forum Stats
Member
Level 17
Animator
Response to What is happening here!?!?! Jul. 5th, 2012 @ 08:04 PM Reply

One fix you could try would be to change the frame rate for your animation. Sometimes if it is at 24fps the sound comes out of sync, but you can fix it by changing the frame rate to something slightly different, like 23.95 fps.

MacDonaldFin
MacDonaldFin
  • Member since: Feb. 6, 2008
  • Offline.
Forum Stats
Member
Level 29
Animator
Response to What is happening here!?!?! Jul. 6th, 2012 @ 12:58 PM Reply

I believe I had the same problem while working on one of my Phoenix Wrong flashes and what I did was:
File>Publish Settings>Audio Stream/Audio Event (depends if you chose to play your sounds as streams or events, but if you did both just change the settings of both stream and event)

Then I changed the bit rate from 16kps to 24kps. This fixed the problem of the sound playing out of sync immediately. So yeah, basically change your bit rate to any higher than your current setting. Hope that helps.

Jomillex
Jomillex
  • Member since: Jul. 27, 2009
  • Offline.
Forum Stats
Member
Level 12
Animator
Response to What is happening here!?!?! Jul. 6th, 2012 @ 01:43 PM Reply

At 6/29/12 08:46 PM, RyanAndIdk wrote: I finished my entire animation an put the sounds in the right spot but it keeps playing before its supposed to! i went through the animation and took out all the tweens but it proceeds to play the sound on a different fame! This has happened before and i took about an hour trying to figure it out but each time it still wouldn't work! I got so frustrated i smashed my hand on my desk and nearly sprained it please help!

Its okay calm down. This has happened to me before. Just squeeze your hand with the opposing one and if you feel a sharp pain then you have fractured it. Smashing your hand will not sprain it since sprains are from overworking one of the muscles.
Source: Google


"So we beat on, boats against the current, borne back ceaselessly into the past."
-F. Scott Fitzgerald

BBS Signature
Pegosho
Pegosho
  • Member since: Nov. 17, 2008
  • Offline.
Forum Stats
Member
Level 13
Animator
Response to What is happening here!?!?! Jul. 6th, 2012 @ 02:52 PM Reply

Do what MacDonladFin said, the more you increase the bit rate the more synchronized everything will be. So if 24 kbps doesn't work, try 64 kbps and so on.